File Menu

The File menu contains options to control creating, opening, closing, and saving VSimComposer files and simulation directories. See Fig. 17.

file menu

Fig. 17 File Menu

New

File -> New has three options:

  • From Example
  • Simulation
  • Text-setup Simulation

For more information on each of these options, please see Creating or Opening a Simulation

Open Simulation

To open a directory where existing simulation files reside, select Open Simulation from the File menu. See Fig. 18.

file menu open simulation

Fig. 18 Open selection from File menu

The default directory, simulations, is created for you during installation of VSim. You can modify this in the Tools -> Settings -> Host settings -> Paths menu. See Fig. 19.

file menu open simulation window

Fig. 19 Open Simulation window

Save Simulation

After a simulation is open, going to File -> Save Simulation allows you to save any modifications to the input file. The saving process will also run the Python pre-processor on the file in order to do any Python substitutions or calculations and to create the .in file.

Save Simulation As

After a simulation is open, clicking on File -> Save Simulation As allows you to save any modifications to the input file and write it in to a new file. The saving process will also run the Python pre-processor on the file in order to do any Python substitutions or calculations and to create the .in file.

Close Simulation

After a simulation is open, File -> Close Simulation allows you to close the current simulation and will return you to the Welcome window.

Open Auxiliary File

This can be used to open any file related to a simulation. It is most useful for opening and editing Python files. Many times, a simulation will have an associated Python file that contains script for post-processing in the Analyze window or for importing an external magnetic field.

Save Auxiliary File

This can be used to save any changes made to an auxiliary file.

Close Auxiliary File

This can be used to close an associated auxiliary file that was previously opened.

Import

When doing a visual-setup simulation, use the File -> Import option to import materials or geometries to use in your simulation.

Materials files must be of the extension “.vmat”

Geometry files can be any of .stl, .ply, .vtk, .stp, .step or .p12.

Recent Simulations

To access data to visualize from a recently conducted simulation, select Recent Simulations from the File menu in the menu bar. See Fig. 20.

recent simulation menu

Fig. 20 Recent Simulation Selection in File Menu

Click on the name of the simulation whose data you want to open.

Quit

File -> Quit will close VSimComposer.